Config Issue - adodotnetservicesphp_path

Sep 28, 2009 at 5:41 PM

I am having trouble getting PHP.INI configuration changes in place. . This is what my ini file looks like now

; Windows: "\path1;\path2"
;include_path = ".;c:\php\includes
include_path = ".;C:\Program Files\PHP\adodotnetservicesphp"  
;PHP Toolkit for ADO .NET Data Services Library Path 
adodotnetservicesphp_path = "C:\Program Files\PHP\adodotnetservicesphp" 

I am receiving the following error when I run the following

C:\Program Files\PHP> php adodotnetservicesphp\PHPDataSvcUtil.php /uri:http://myAzureapp.cloudapp.net/myService.svc/

Error generating proxy classes. The configuration option 'adodotnetservicesphp_p
ath' is not set in the php.ini file, Please refer installation instructions for
fix this issue

Any thoughts?

Also - I installed PHP using the WPI 2.0 (Web Platform Installer) and the version of PHP that is currently being loaded does not contain the php_xsl.dll

Thanks

Coordinator
Sep 29, 2009 at 5:16 AM
Edited Sep 29, 2009 at 3:16 PM

Hi Nickknyc,

Did you restart IIS after changing PHP.INI ? if not can you try it?

For adding php_xsl.dll, Please follow the below steps:

1. Download the PHP zip package in a temporary folder from http://www.php.net/downloads.php corresponding to your PHP version

2. Extract the zip, from %Temporary Folder%\PHP version\ext\ copy php_xsl.dll to ext directory of your PHP installation directory.

3. Modify PHP.INI file to enable xsl extension, for this add following line under  Dynamic Extensions section

         extension=php_xsl.dll

4. Restart IIS

 

Thanks

Anu